Error Codeigniter 3.15: mysqli::real_connect(): Headers and client library minor version mismatch

Codeigniter
Codeigniter

Server yang saya pakai biasanya menggunakan codeigniter 2.12, sehingga ketika update php ataupun mariaDB tidak pernah mengalami masalah. Ketika saya menggunakan Codeigniter 3.15, terjadi error pada halaman Welcome

Sehingga muncul pertanyaan, kenapa header dan client library berbeda muncul peringatan pada aplikasi. Untuk mengatasi hal tersebut yaitu cukup menginstall mysql native driver untuk PHP. Karena server saya menggunakan debian cukup ketik perintah:

secara otomatis akan meremove php5-mysql yang ada pada server.

Sebelum menguji coba server saya, saya lakukan perintah restart pada apache 2 server saya

selanjutnya peringatan error pada Codeigniter akan menghilang.

,,,,

Tinggalkan Balasan

This site uses Akismet to reduce spam. Learn how your comment data is processed.