WP automatic Upgrade konflik dengan WordPress Update core

WordPress 2.7 merupakan perubahan besar dari WordPress. Kira-kira sebulan yang lalu, WordPress meluncurkan upgrade 2.7.1. WordPress 2.7 telah terintegrasi fitur update langsung tanpa harus melewati file manager atau ftp lagi.
Dahulu saya menggunakan WP-automatic Upgrade untuk upgrade otomatis dengan beberapa kali klik pada dari menu automatic upgrade. Karena fitur WordPress 2.7 sudah cukup untuk saya, maka saya tidak menggunakan WP-Automatic Upgrade lagi. Tapi ternyata saya lupa untuk menonaktifkan plugin WP-Automatic Upgrade ini. Dan akhirnya:

Downloading update from http://wordpress.org/wordpress-2.7.1.zip

Unpacking the core update

Fatal error: Cannot redeclare pclziputilpathreduction() (previously declared in /home/user/public_html/wp-content/plugins/wordpress-automatic-upgrade/lib/pclzip.lib.php:5421) in /home/user/public_html/wp-admin/includes/class-pclzip.php on line 5498

Awalnya saya pikir gara-gara pindah server dan servernya beda spesifikasi. Ternyata saya cek plugin WP-Automatic Upgrade masih aktif. Setelah saya nonaktifkan, alhamdulillah proses upgrade lancar.

4 thoughts on “WP automatic Upgrade konflik dengan WordPress Update core

  1. @Rosyidi : Kegagalan proses upgrade umumnya terjadi karena kegagalan komunikasi antara server hosting dengan server plugins/wp. Saya pernah mengalami hal ini saat hosting down.

Leave a Reply

Your email address will not be published. Required fields are marked *